Fork me on GitHub Fork me on GitHub
Komantarze - problem z wysyłaniem komentarzy - bi




Bottom   Previous Topic   Next Topic  Register To Post



Komantarze - problem z wysyłaniem komentarzy - biała strona to jedyny efekt wysłania komentarza.
#1
Rozkręcam się

2
User information
Witam ponownie...
System Xoops potrafię postawić w kilka minut o ile wszystko gra - nie jestem informatykiem. Stronka do której użyłem Xoops'a jest prosta stronką stworzoną tylko dla czterech przyjaciół - pasjonatów fotografii. W założeniu było że ma być tania i łatwa w utrzymaniu przez lata. Xoops jest wiec do tego idealny... gorzej z serwerem na którym musi pracować. Spośród wielu ofert wybór padł na darmowy )
I tak mordujemy się na nim od kilku lat. Xoops działa na nim pięknie ale co jakiś czas pojawia się problem z komentarzami. Kłopot polega na tym ze komentarze przestają chcieć się ładować na stronie. Po wpisaniu komentarza i klknięciu na pole 'Napisz komentarz' pojawia się biała strona i komentarz nie zostaje wysłany na serwer a w konsekwencji nie pojawia się na stronie. Dość mocno to denerwuje userów i jakoś nie ma na to rady... Przeinstalowałem XOOPS'a, potem postawiłem go od nowa w najnowszej polskiej wersji i wszystko działało poprawnie kilka dni. Teraz znowu zaczynają się kłopoty... na razie zauważyłem to u mnie. Próbowałem z różnych przeglądarek wysyłać komentarz i nie dało się - efektem jest BIAŁA STRONA w przeglądarce - po odczekaniu stosownej chwili klikając na cofnij wracam do strony z wpisanym komentarzem ale kolejne próby publikacji spełzają na niczym - jest biała strona.
Wie może ktoś co zrobić w takim przypadku? Proszę o pomoc.
Pozdrawiam.

Posted on: 2013/10/6 12:21
Print Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Report Top


Re: Komantarze - problem z wysyłaniem komentarzy - biała strona to jedyny efekt wysłania komentarza.
#2
Rozkręcam się

2
User information
Wpadłem na pomysł włączenia debugowania... i oto wynik po nieudanym komentarzu. Jeśli zerknął na to ktoś kto to rozumie to bardzo proszę o poradę co mam zrobić...

"; debug_window.document.writeln("
"; debug_window.document.writeln("
"; debug_window.document.writeln("??adne (None)<\/a>"; debug_window.document.writeln("Wszystkie (All)<\/a>"; debug_window.document.writeln("B??Ä?dy (Errors) (0)<\/a>"; debug_window.document.writeln("Przestarza??e (Deprecated) (0)<\/a>"; debug_window.document.writeln("Zapytania (Queries) (8)<\/a>"; debug_window.document.writeln("Bloki (Blocks) (0)<\/a>"; debug_window.document.writeln("Dodatkowe (Extra) (2)<\/a>"; debug_window.document.writeln("Czasy ??adowania (Timers)(3)<\/a>"; debug_window.document.writeln("<\/div>"; debug_window.document.writeln("
B??Ä?dy (Errors)<\/th><\/tr>"; debug_window.document.writeln("<\/table>"; debug_window.document.writeln("
Przestarza??e (Deprecated)<\/th><\/tr>"; debug_window.document.writeln("<\/table>"; debug_window.document.writeln("
Zapytania (Queries)<\/th><\/tr>
0.000292 - SET NAMES 'utf8'<\/td><\/tr>
0.000160 - SET SQL_BIG_SELECTS = 1<\/td><\/tr>
0.000291 - SELECT * FROM config WHERE (conf_modid = '0' AND conf_catid = '1') ORDER BY conf_order ASC<\/td><\/tr>
0.000343 - SELECT sess_data, sess_ip FROM session WHERE sess_id = 'baaba140c876e90136c4beb8cdb3c8ce'<\/td><\/tr>
0.000279 - SELECT * FROM users WHERE uid = '1'<\/td><\/tr>
0.000255 - SELECT * FROM modules WHERE dirname = 'extgallery'<\/td><\/tr>
0.000621 - SELECT * FROM config WHERE (conf_modid = '2') ORDER BY conf_order ASC<\/td><\/tr>
0.000262 - SELECT * FROM group_permission WHERE (gperm_name = 'public_upload' AND gperm_modid = '2' AND (gperm_groupid = '1' OR gperm_groupid = '2'))<\/td><\/tr>
Razem: 8<\/span><\/td><\/tr><\/table>
Bloki (Blocks)<\/th><\/tr>
Razem: 0<\/span><\/td><\/tr><\/table>
Dodatkowe (Extra)<\/th><\/tr>
Included files:<\/strong> 57 plik??w<\/td><\/tr>
Zu??ycie pamiÄ?ci:<\/strong> 7180328 bytes<\/td><\/tr><\/table>
Czasy ??adowania (Timers)<\/th><\/tr>
XOOPS<\/strong> zajÄ???o 0.121<\/span> sekund na za??adowanie.<\/td><\/tr>
XOOPS Boot<\/strong> zajÄ???o 0.096<\/span> sekund na za??adowanie.<\/td><\/tr>
Module init<\/strong> zajÄ???o 0.025<\/span> sekund na za??adowanie.<\/td><\/tr><\/table><\/div>"; debug_window.document.writeln("

Posted on: 2013/10/9 22:46
Print Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Report Top


Re: Komantarze - problem z wysyłaniem komentarzy - biała strona to jedyny efekt wysłania komentarza.
#3
Xoopser

2
User information
Jak już coś wklejasz do analizy to postaraj się by było takie samo jak oryginał, a nie przekonwertowane. Jak nie wiesz jak to zrobić to wrzuć zrzut ekranu lepiej.
Nie widzę błędu w tym debugu. Możesz spróbować debug z opcją SMARTY, ale i tak to raczej strata czasu.
Problem białej strony gryzie Xoopsa od wielu lat i nie ma jednego uniwersalnego rozwiązania. Może wynikać z nietypowej konfiguracji serwera hostingowego, co w Twoim przypadku jest wysoce prawdopodobne. Najprościej jakbyś zrobił sobie kopie strony na lokalnym komputerze - od razu wyeliminujesz błędy "wewnątrz Xoopsa" (choć nie wykluczam i tego ze wskazaniem na moduł lub prawa dostępu).

Posted on: 2013/10/11 17:10
Print Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Report Top


Re: Komantarze - problem z wysyłaniem komentarzy - biała strona to jedyny efekt wysłania komentarza.
#4
Rozkręcam się

2
User information
Przepraszam, ale pojęcia nie miałem że tak to będzie wyglądało po naciśnięciu 'Submit'
Problem białej strony oczywiście pojawiał się u mnie również wcześniej jednak był ktoś kto potrafił znaleźć na to radę. Niestety kontakt się urwał i teraz już Xoops został bez stosownej opieki. Poprawiany był Xoops w wielu miejscach i dopasowywany do serwera - jednak teraz po przeinstalowaniu pogubił sie - jak myślę - i kłopot jest.
Może jeszcze przeczyta to ktoś, kto miał podobny przypadek i dał radę.
Dziękuję Ci Jagi za odzew...
Pozdrawiam.

Posted on: 2013/10/11 20:47
Print Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Report Top


Re: Komantarze - problem z wysyłaniem komentarzy - biała strona to jedyny efekt wysłania komentarza.
#5
Xoopser

2
User information
Podaj jaką masz wersję Xoopsa, jaka wersja modułu, w którym padły komentarze, jaka wersja PHP i mysql na serwerze, wersja Apache czy co tam jest.
Czy wiesz dokładnie jakie zmiany o których mówiłeś były wprowadzane?

Posted on: 2013/10/11 21:41
Print Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Report Top


Re: Komantarze - problem z wysyłaniem komentarzy - biała strona to jedyny efekt wysłania komentarza.
#6
Rozkręcam się

2
User information
XOOPS Wersja XOOPS 2.5.6
PHP Wersja 5.3.4
mySQL Wersja 5.1.66-0+squeeze1-log
Server API apache2handler
OS Linux
safe_mode Off
register_globals Off
magic_quotes_gpc On
allow_url_fopen Off
fsockopen Off
post_max_size 3072K
max_input_time 60
output_buffering 4096
max_execution_time 20
memory_limit 128M
file_uploads On
upload_max_filesize 3072K
+++++++++++++++++++++++++++++
W tym module - poniżej - padły komentarze.
eXtGallery is a powerful web gallery module for XOOPS
2013-08-12: Version 1.12 Beta 1
+++++++++++++++++++++++++++++

Co było zmieniane i w jakich skryptach tego nie wiem gdyż nie było to robione ani w moim towarzystwie ani na moim kompie.

Posted on: 2013/10/11 22:26
Print Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Report Top


Re: Komantarze - problem z wysyłaniem komentarzy - biała strona to jedyny efekt wysłania komentarza.
#7
Xoopser

2
User information
Nie masz "staroci". Jak twierdzisz, że działało kilka dni, to coś zmieniło na serwerze i to nie samo (przeżyłem to wielokrotnie na płatnym serwerze). Szukanie zmian we własnym zakresie to strata czasu. Spróbuj skontaktować się z adminem serwera, choć przy bezpłatnym koncie możesz nie otrzymać pomocy...

P.S. przypadek z tego forum (luxer) : niedziałająca jedna z funkcji Xoopsa ..
i odpowiedź BOK'u
"Znieczulenie systemu ochrony serwera na działanie Pani skryptów (imagemanager.php) zostało wprowadzone dla konta ..."

Posted on: 2013/10/13 10:35
Print Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Report Top







You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.
You cannot use topic type.
You cannot use HTML syntax.
You cannot use signature.

[Advanced Search]